import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\p{Lu}\\p{Ll}+ )+)";
final String string = "Tortillas Bolsa 2a 1kg 4118\n"
+ "Tortillinas 50p 1 31Kg TAB TR 46113\n"
+ "Bollos BK 4in 36p 1635g SL 131\n"
+ "Super Pan Bco Ajonjoli 680g SP WON 100 \n"
+ "Pan Blanco Bimbo Rendidor 567g BIM 49973\n"
+ "Gansito ME 5p 250g MTA MLA 49860";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}