# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\p{Lu}\p{Ll}+ )+)"
test_str = ("Tortillas Bolsa 2a 1kg 4118\n"
"Tortillinas 50p 1 31Kg TAB TR 46113\n"
"Bollos BK 4in 36p 1635g SL 131\n"
"Super Pan Bco Ajonjoli 680g SP WON 100 \n"
"Pan Blanco Bimbo Rendidor 567g BIM 49973\n"
"Gansito ME 5p 250g MTA MLA 49860")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.