package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)//(.*):(.*)@`)
var str = `XXX url=https://username:password@host:port/path response_code=200 return_code=ok`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}