re = /\/\/(.*):(.*)@/m
str = 'XXX url=https://username:password@host:port/path response_code=200 return_code=ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end