using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)-(\w+)\s+(\""[^\""]*\""|[^\s\""-]+(?:\s+[^\s\""-]+)*)(?!\S)";
string input = @"-desc none -type used -cost med -color blue
-desc none -msg This is a a message -name test
-desc ""(-type old -cost high)"" -color green -asdf ""sdbgf""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}