const regex = new RegExp('(?<!\\S)-(\\w+)\\s+(\\"[^\\"]*\\"|[^\\s\\"-]+(?:\\s+[^\\s\\"-]+)*)(?!\\S)', 'g')
const str = `-desc none -type used -cost med -color blue
-desc none -msg This is a a message -name test
-desc "(-type old -cost high)" -color green -asdf "sdbgf"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}