$re = '/\w{10}(?=\w)/m';
$str = 'Pneumonoultramicroscopicsilicovolcanoconiosis is a really long word
It\'s a name that has been invented for a lung disease caused by breathing in very small pieces of ash or dust
Pneumono refers to the lung. Ultra means extremely, microscopic means tiny, silica is sand, volcano is self-evident, and coniosis is scarring.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);