import re
regex = re.compile(r"\w{10}(?=\w)", flags=re.MULTILINE)
test_str = ("Pneumonoultramicroscopicsilicovolcanoconiosis is a really long word\n"
"It's a name that has been invented for a lung disease caused by breathing in very small pieces of ash or dust\n"
"Pneumono refers to the lung. Ultra means extremely, microscopic means tiny, silica is sand, volcano is self-evident, and coniosis is scarring.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")