using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=null,).*?(?=,null,\d{1,3}(?:,|$))|(?<=chara"":|motion"":)[^,\n]*";
string input = @"},null,""「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」"",""「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」""],[""player"",null,""「利用……?」"",null,64,{
""data"": [[""bg"",""stage"",{
""action"": [[""zpos"",233.33333333333337]],
""class"": ""stage"",
""name"": ""bg"",
""redraw"": {
""disp"": 2,
""imageFile"": {
""file"": ""bg03.mtn"",
""options"": {
""chara"": ""背景"",
""motion"": ""昼""
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}