re = /(?<=null,).*?(?=,null,\d{1,3}(?:,|$))|(?<=chara":|motion":)[^,\n]*/m
str = '},null,"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」","「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」"],["player",null,"「利用……?」",null,64,{
"data": [["bg","stage",{
"action": [["zpos",233.33333333333337]],
"class": "stage",
"name": "bg",
"redraw": {
"disp": 2,
"imageFile": {
"file": "bg03.mtn",
"options": {
"chara": "背景",
"motion": "昼"
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end