$re = '/(?!^|"$)["\']/m';
$str = '"The"
"quick brown"" fox "jumps over the"
"lazy dog"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;