package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[a-z0-9]*\d[a-z0-9]*`)
var str = `78784
aZ837
987Ny
19hd35
fc82pl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}