$re = '/[a-z0-9]*\d[a-z0-9]*/mi';
$str = '78784
aZ837
987Ny
19hd35
fc82pl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);