package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+-(?<month>\d{2})-(?<year>\d{4})`)
var str = `Date-01-2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}