$re = '/\w+-(?<month>\d{2})-(?<year>\d{4})/';
$str = 'Date-01-2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);