using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(123)";
string input = @"123684
123125
454521235745";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}