$re = '/^(?!.*404).*\.php/m';
$str = 'fjkhkdfh.php
404.php
dfjhkdj.php
djsdh404.php
fdf404dfd.php
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);