re = /^(?!.*404).*\.php/m
str = 'fjkhkdfh.php
404.php
dfjhkdj.php
djsdh404.php
fdf404dfd.php
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end