package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,3})+$`)
var str = `somethingverylong@hereandthereseemore-.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}