re = /^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,3})+$/
str = 'somethingverylong@hereandthereseemore-.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end