package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*m)?\d*[sm]$`)
var str = `30s
5m
5m30s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}