$re = '`^(\d*m)?\d*[sm]$`m';
$str = '30s
5m
5m30s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);