package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ErrorMessage\=\s+(?<ErrorMessage>[^:]*)`)
var str = `Number=Test1,Code=DPCA , ErrorMessage= sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}