re = /ErrorMessage\=\s+(?<ErrorMessage>[^:]*)/m
str = 'Number=Test1,Code=DPCA , ErrorMessage= sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end