import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)/\\h*\\*.*?\\*\\h*/";
final String string = "{\n"
+ " CALLING_NBR = 1, / * nn svjfv ks;am scjv * /\n"
+ " CALLED_NBR = 2, / * ssvdsv * / \n"
+ " EVENT_BEGIN_TIME = 3, / * * / \n"
+ " DURATION = 4, / * dhuf bvhsbv sjkncjsv jsvnjsdbv \n"
+ " the value of rthe vbisu * / \n"
+ " BILLING_PREFIX = 5 ,\n"
+ " CALLING_CIRCLE_TYPE_ID = 6,\n\n"
+ " CALL_TYPE = 7, / * call type* / \n"
+ "CALLING_PREFIX = 8, / * calling e * / ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}