// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)/\h*\*.*?\*\h*/").unwrap();
let string = "{
CALLING_NBR = 1, / * nn svjfv ks;am scjv * /
CALLED_NBR = 2, / * ssvdsv * /
EVENT_BEGIN_TIME = 3, / * * /
DURATION = 4, / * dhuf bvhsbv sjkncjsv jsvnjsdbv
the value of rthe vbisu * /
BILLING_PREFIX = 5 ,
CALLING_CIRCLE_TYPE_ID = 6,
CALL_TYPE = 7, / * call type* /
CALLING_PREFIX = 8, / * calling e * / ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}