package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{3}\d{8,15}`)
var str = `AB# 33805717- 00 R/E FROM NA#52198052- 00
SOS 032122 TO 032122, TOTAL BILLED $2
OA FILMED UFE: 920220831200900
FILM NUMBER: VRG40947802 REC DATE: 070222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}