$re = '/[A-Z]{3}\d{8,15}/m';
$str = 'AB# 33805717- 00 R/E FROM NA#52198052- 00
SOS 032122 TO 032122, TOTAL BILLED $2
OA FILMED UFE: 920220831200900
FILM NUMBER: VRG40947802 REC DATE: 070222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);