import re
regex = re.compile(r"\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)", flags=re.MULTILINE)
test_str = ("(2000)\n"
"(2000, 435)\n"
"(2000 435)\n"
"(2000, 435-67)\n"
"(2000 435-67)\n"
"(2000 435-67, 71)\n"
"(2000, 435-67, 71)\n"
"(2000, 435-67, 71-4)https://regex101.com/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")