import Foundation
let pattern = #"\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(2000)
(2000, 435)
(2000 435)
(2000, 435-67)
(2000 435-67)
(2000 435-67, 71)
(2000, 435-67, 71)
(2000, 435-67, 71-4)https://regex101.com/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)