re = /\b(NUMBER|[XYZAB])\:=([^,]+),/
str = 'DRILL(NUMBER:=20,NAME:=\'4\',PN:=1,X:=10.1,Y:=73.344,Z:=0,A:=-1.435,B:=1.045,M1:=1,M2:=2,M3:=3,M4:=4,M5:=1,S1:=10.5,S2:=2.1,S3:=1.2,S4:=2,S5:=2.4,RS1:=1,RS2:=2);
NUMBER, X, Y, Z, A, B
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end