import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2}\\: (.+)\\: \\<(.+)\\>.*mtu (\\d+).*state (UP|DOWN|UNKNOWN).*\\n.*|\\n.*inet (\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})\\/\\d{1,2})";
final String string = "1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000\n"
+ " link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00\n"
+ " inet 127.0.0.1/8 scope host lo\n"
+ " valid_lft forever preferred_lft forever\n"
+ " inet6 ::1/128 scope host\n"
+ " valid_lft forever preferred_lft forever\n"
+ "2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000\n"
+ " link/ether b8:27:eb:30:65:42 brd ff:ff:ff:ff:ff:ff\n"
+ "3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000\n"
+ " link/ether b8:27:eb:65:30:17 brd ff:ff:ff:ff:ff:ff\n"
+ " inet 192.168.178.22/24 brd 192.168.178.255 scope global dynamic noprefixroute wlan0\n"
+ " valid_lft 861425sec preferred_lft 753425sec\n"
+ " inet6 fe80::d32b:df6a:d0e1:d925/64 scope link\n"
+ " valid_lft forever preferred_lft forever";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}