package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z]*`)
var str = `The car parked in the garage #21.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}