$re = '/[a-z]*/';
$str = 'The car parked in the garage #21.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);