package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,]+,)[, ]+`)
var str = `new york, ,ny usa
`
var substitution = "\1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}