use strict;
my $str = 'new york, ,ny usa
';
my $regex = qr/([^,]+,)[, ]+/mp;
my $subst = '\\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";