#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([\d,*\/-]*\s+){3}(\(LW\)|[\d,*?\/-]+)\s+((?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC|[\d,*?\/#-]+)(?:\s*,\s*(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC|[\d,*?\/#-]+))*)\s*((?:SUN|MON|TUE|WED|THU|FRI|SAT|\(LW\)|[\d*?\/#-]+)(?:\s*(?:SUN|MON|TUE|WED|THU|FRI|SAT|\(LW\)|[\d*?\/#-]+))*)([\d,*\/#-]*)$"
Local $sString = "0/5 14,18,3-39,52 * ? JAN,MAR,SEP MON-FRI 2002-2010" & @CRLF & _
"0/5 14,18,3-39,52 * ? JAAN,MAR,SEP MON-FRI 2002-2010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")