const regex = new RegExp('^([\\d,*\\/-]*\\s+){3}(\\(LW\\)|[\\d,*?\\/-]+)\\s+((?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC|[\\d,*?\\/#-]+)(?:\\s*,\\s*(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC|[\\d,*?\\/#-]+))*)\\s*((?:SUN|MON|TUE|WED|THU|FRI|SAT|\\(LW\\)|[\\d*?\\/#-]+)(?:\\s*(?:SUN|MON|TUE|WED|THU|FRI|SAT|\\(LW\\)|[\\d*?\\/#-]+))*)([\\d,*\\/#-]*)$', 'gim')
const str = `0/5 14,18,3-39,52 * ? JAN,MAR,SEP MON-FRI 2002-2010
0/5 14,18,3-39,52 * ? JAAN,MAR,SEP MON-FRI 2002-2010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}