using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$([^\s$]*)\$";
string input = @"The price is between $400 and $500.
The price is between $400$ and $500$.
The price is between $old_value$ and $new_value$.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}