package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$([^\s$]*)\$`)
var str = `The price is between $400 and $500.
The price is between $400$ and $500$.
The price is between $old_value$ and $new_value$.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}