const regex = /(\d+\.\s.*(?:\r\n?|\n)+)(?:\r\n?|\n)(?=•\s{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.\\s.*(?:\\r\\n?|\\n)+)(?:\\r\\n?|\\n)(?=•\\s{3})', 'gm')
const str = `1. Hello
• World
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);