re = /(\d+\.\s.*(?:\r\n?|\n)+)(?:\r\n?|\n)(?=•\s{3})/m
str = '1. Hello
• World
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result