# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(•\s{3}.*(?:\r\n?|\n)+)(?:\r\n?|\n)(?=\d+\.\s)/$1/gm;t' <<< "• World
1. Hello
"