const regex = /(•\s{3}.*(?:\r\n?|\n)+)(?:\r\n?|\n)(?=\d+\.\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(•\\s{3}.*(?:\\r\\n?|\\n)+)(?:\\r\\n?|\\n)(?=\\d+\\.\\s)', 'gm')
const str = `• World
1. Hello
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);