# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b106\b"
test_str = ("No match:\n"
"106M\n"
"1106\n"
"106in a string is bad even if it starts the line\n"
"And it may finish with the target but not as the tail of a string106\n\n"
"Match:\n"
"106 something else\n"
"another 106\n"
"And ofcouse \"106' will work as well\n"
"I just want 106 to show up but not embedded in other numbers or text\n"
"but it's OK is the end of the line is 106\n"
"106 may also start the line but")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.