// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b106\b").unwrap();
let string = "No match:
106M
1106
106in a string is bad even if it starts the line
And it may finish with the target but not as the tail of a string106
Match:
106 something else
another 106
And ofcouse \"106' will work as well
I just want 106 to show up but not embedded in other numbers or text
but it's OK is the end of the line is 106
106 may also start the line but";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}