using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^AEOUI\P{Lu}]";
string input = @"ABcDeFO!.
.½§1234567890!""#¤%&/()=?´@£${[]}~*\'¨-_.,;:><| åäö";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}