re = /[^AEOUI\P{Lu}]/
str = 'ABcDeFO!.
.½§1234567890!"#¤%&/()=?´@£${[]}~*\\\'¨-_.,;:><| åäö'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end