const regex = /(^|\s)\d[^\s]*\.+[^\s]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)\\d[^\\s]*\\.+[^\\s]*', 'gm')
const str = `lorum3 ipsum 15.2.3.9.7 bar foo 1. v more text 46 2. here and even more text here v7.8.989 7.a.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}