re = /(^|\s)\d[^\s]*\.+[^\s]*/m
str = 'lorum3 ipsum 15.2.3.9.7 bar foo 1. v more text 46 2. here and even more text here v7.8.989 7.a.0.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end